I have a number of blogs running from one hosting account at GoDaddy (I'm not proud). I have 3 different themes running on these sites and all perform without any problems.

I loaded Arctica and I cannot get a page back in under 10 seconds.
I have deleted the entire site twise and the WP installation and loaded a completely vanilla setup with only the default pages imported. I get a response in under 200ms from the site but . . . the first page (and all subsequent pages) takes over 10 seconds to actually appear. Usually it takes 13+ seconds.

I have a default page up while I am trying to resolve this issue and you'll see latency is not an issue.

Thoughts?

For faster issue resolution please provide:

URL to your website: www.spurart.at/wordpress
another site on the same host: www.englishintirol.com (for comparison)
Browser version: all Firefox, Safari, Chrome, EI9
Theme version: Arctica 1.16 (latest)
September 17, 2012, 10:05am
Note: once the pages starts to load, it is loads all elements in under 2 seconds normally.
September 17, 2012, 10:06am

I have loaded WP Super cache with prefetching enabled. I am still using the default site created by importing the default file. The theme appears to get stuck when loading the following: http://spurart.at/wordpress/wp-content/themes/img/icon-menu-shd.png

This takes over 11 seconds.

I am using http://tools.pingdom.com/fpt/ to verify load times.

September 17, 2012, 12:01pm

AIT Supportivan
Hi, sorry about that but with this we can't help you. We are using WP super cache plugin on our preview page, and you can see that the site load is not too slow.
http://preview.ait-themes.com/arctica/wp1/
Thanks, Ivan.
September 18, 2012, 3:37am

I'm sorry? I am using the EXACT SAME config you are using. I have loaded WP super cache as you have specified! I have identified the exact file that is causing the problem.

I ran the SAME TEST against your preview page I GET THE SAME problem.

http://tools.pingdom.com/fpt/#!/GLbsE0OFF/http://preview.ait-themes.com/arctica/wp1/

This is a bug. Pure and simple. If you need more information, I am happy to provide it. But Arctica (as pretty as it is) is UNUSEABLE if it takes 15 seconds to load.

Please could you take a look at the very specific issue I have raised. It even happens on a localhost. I know, I tested it.

Thanks.
September 18, 2012, 6:33am

AIT Supportivan
Hi, we tested this site and still with cleared cache page load under 7sec. With test page you sent, i receive still load time under 8 sec.
As I said, really cant do anything with this now. User still can look at preview page and decide if it is fine template for him or not.

Thanks, Ivan.
September 19, 2012, 3:03am

Hi Ivan,
Here's what I have found:

This link: http://spurart.at/wordpress/wp-content/themes/img/icon-menu-shd.png
Was slowing the whole page down because . . . it is pointing to a graphic that doesn't exist! This is a bug. The link is incorrect. Copying the graphic to the incorrect location specified resulted in a 4 second improvement across browsers.

Administration is a nightmare because of speed. I am waiting 15 seconds to update a page. This morning I ran a test and it turns out that just getting to the wp-admin screen causes the following graphics to be called: NONE OF WHICH ARE LOCATED WHERE SPECIFIED. This again dramatically reduces performance. Caching does not help if the references are incorrect. Here's a partial list from the wp-admin page.

facebook.png spurart.at/wordpress/undefined/design…
twitter.png spurart.at/wordpress/undefined/design…
delicious.png spurart.at/wordpress/undefined/design…
digg.png spurart.at/wordpress/undefined/design…
linkedin.png spurart.at/wordpress/undefined/design…
reddit.png spurart.at/wordpress/undefined/design…
stumbleupon.png spurart.at/wordpress/undefined/design…
tumblr.png spurart.at/wordpress/undefined/design…

These types of performance issues are easily resolved (no pun intended). Perhaps running a link check against this version? I do not want to start creating a new file structure to fix this. It means upgrading will be problematic. I am not asking you to rewrite php scripts, I'd just like the references to be correct.

Please?

Thanks

September 19, 2012, 6:09am

September 19, 2012, 6:10am

Spur is totally right on this. 13secs to load a page is unacceptable. I'm seriously thinking of using another theme if this problem is not solved. Arctica is UNUSEABLE like this.
September 20, 2012, 4:21am

try to disable slider feature.
In the homepage.php, the function getimagesize that is called for each image of the slider.
if the url set in the slider settings are expressed in http, the theme is a call for each image by asking the size of the file.
This dramatically increases the load time of the page.
September 24, 2012, 6:34pm

Hi dennistiboni, Thanks for your input. I took a look for getimagesizes and found it. But I am not a php programmer.
I took a look at the slide settings in the theme. Under 'Slider Items Options' the first two items are 'Image' and 'Link'. I have an image specified in all cases. I do not have a link specified. I think, this means I am already doing what you are suggesting. Is this correct?

Again, thanks for the response.
September 25, 2012, 7:51am